Mobile Network Service Disruption
Resolved
Duration: 16h 10mJun 28, 2026Affected services
Device Connectivity
Operational
Timeline
Resolved
22:10Jun 28, 20265d ago
Wir haben den Incident behoben.
Investigating
06:00Jun 28, 20266d ago
On Sunday, June 28, 2026, our mobile network provider experienced a temporary service disruption affecting the operational availability of our mobile services. The incident lasted approximately 16 hours and 10 minutes.
At 22:10 GMT+2 on June 28, 2026, all services were confirmed to be fully restored. No further impact has been observed as of the time of this report.
