We are investigating degraded performance affecting the user interface and API.

  • Now
  • Aug 18, 2025, 3:49:08 PM GMT+2
    Resolved

    After closely monitoring the affected server and related services, we have confirmed that Access, Application data, and Data Provisioning are all back up and running as expected. The recent changes implemented to address degraded performance have proven effective, and no further issues have been observed during the monitoring period. We appreciate your patience throughout this incident and can confirm that all services are now fully operational.

  • Aug 13, 2025, 10:27:38 AM GMT+2
    Monitoring

    Following our previous investigation, we implemented adaptions to address the degraded performance affecting Access, Application data, and Data Provisioning. These changes have resulted in noticeably more stable service performance. At this stage, we are closely monitoring all affected services to ensure that the improvements are sustained over the long term. We will continue to observe system behavior and provide further updates as needed.

  • Aug 8, 2025, 11:08:12 AM GMT+2
    Investigating

    After identifying initial issues, we have been able to slightly improve the performance of the affected services. The root cause of the incident has been narrowed down to our internally hosted myDatanet server. Customer-specific hosted systems are not affected. The investigation is ongoing to achieve a full resolution.

  • Aug 7, 2025, 12:53:33 PM GMT+2
    Investigating

    We have detected degraded performance impacting both the user interface and API, which may result in slower response times or intermittent issues for users. Our engineering team is actively investigating the root cause and working to restore normal service as quickly as possible. We appreciate your patience and will provide updates as soon as more information is available.

    Application data
    Data Provisioning
    Access